The referenced component 'AxMapWinGIS' could not be found

Hello everyone.
I am new to MapWinGIS.
I have installed MapWinGIS v5.3 in order to use it on visual studio 2022 with C#.
Settings such as inclusion of “Map Control” in the COM components is done.

However, I keep receiving warning: “The referenced component ‘AxMapWinGIS’ could not be found.
In the Solution Explorer the ‘AxMapWinGIS’ is marked as missing.

I haved searched the whole internet and could not find the solution.
Please help to find the missing files/referneces.

Regards Adam

Hello @Adamski

Did you install the 32-bit or the 64-bit version of the OCX. I believe that there are issues with Visual Studio loading a 64-bit version of an Active-x control (at least up through VS2019, I don’t know about VS2022).

Regards,
Jerry.

Hi @jerryfaust, thank you for replying

I am running x64 based Win10 and x64 based VS2022 IDE.
I have installed “MapWinGIS-only-v5.3.0.0-x64-VS2017.exe” from the official site.
Integrated MapWinGis to the VS2022 IDE before use.

As a result VS2022 IDE does see “MapWinGIS.ocx” but doesn’t see “AxMapWinGIS.ocx”
I have tried manually searching for “AxMapWinGIS.ocx” file in the MapWinGIS installation directory (C:\dev\MapWinGIS), but did not Find.

I had also tried to manually search for “AxMapWinGIS.ocx” file on the internet however from my search result such file doesnt seem to exist at all.

Please see attached screenshot for better understanding

Hello @Adamski

The AxMapWinGis.ocx is the Interop COM wrapper that Visual Studio creates in order to use the OCX in the .NET environment. We’re getting a lot of issues recently related to VS2022. I will try to find the time to test the OCX in VS2022 and hopefully determine a solution.

Regards,
Jerry.

Hello, have you found any solution? Im facing with the same problem. Thanks.

Hello all.

From Microsoft’s documentation Breaking API changes in Visual Studio 2022

When you reference an assembly that compiled against the pre-Visual Studio 2022 SDK, you may get an error about missing an assembly reference.

I’m thinking that we simply have to update the project to use VS2022. I’m still not sure about 32 vs 64 bit build, since VS2022 is strictly a 64 bit development environment. I’ll go through the process and see what I can see.

Regards,
Jerry.

Hello again,

I’m just about starting work again on my project - I’d like to start with VisualStudio 2022 right away, as it is pur 64 Bit…

Is there anything new on this topic? Does it work with VS2022?

Thanks

I’ve commented on VS2022 elsewhere. I am using MapWinGIS (5.3) successfully on it, but I am using 64-bit only. Looks like this is fine for you.

Hi Rob,

thanks for your message, but I can’t find the said post.

I’ve set the project to x64 but still can’t see the MapControl - it keeps saying that it is probably not compatible to visualstudio 2022…

Hello again,

I think I figured it out - I changed to dotnet-framework 4.72 and it works - somehow. The app-form, seems somehow to be blurred. Especially the fonts. And on top the map control comes out smaller the it should be. I use two controls (treeView - to display the layers) and a map control side by side with only a minimal space in between. When I start the app the gap turns out to be huge …

Install Mapwingis 32bit, 64bit in the same folder d:\Mapwingis in your directory and produce your software in 64bit framework 4.8
Uploading: image.png…