MapWinGIS 64bit

Hallo everyone.
Does anybody compiled a project for 64bit in VS2017?
I’m trying to compile a project for 64bit the last 2 days with no success.
I tried everything written in forums and github, but nothing. (register, unregister, install both 32 and 64).
Versions 5.3, 5.2.4, 5.1.0, 5.0
While in 32bit everything works OK, when I try in 64bit either I get message that ocx not registered or that AxMapWinGIS not found.
If anybody can give detailed instructions it would be great.

1 Like

Hello @mapl

I’m sorry, but it’s not clear to me whether you’re having trouble building the 64-bit ocx? or using the ocx afterward in another project?


Thanks for your reply,
I have problem using the ocx.
I installed from github a release of mapwingis for 32bit. I make my own 32bit project in using the ocx with no problems.
Now I want to compile my project targeting 64bit. So, I installed also the 64bit version of same release of mapwingis, but when I try to compile I get the errors described earlier.
I tried using vs2017 32bit and vs2017 64bit.
I tried also all releases from 5.0 and afterwards.
Any suggestion?