GeoPackage not loading

UK Ordnance Survey release a fairly extensive GeoPackage here… https://osdatahub.os.uk/downloads/open/OpenZoomstack - it’s 4GB so a hefty download. I can drop that on to a blank map and everything works fine so I know I’m configured correctly (apart from projection errors with the base map tiles as the incoming data is OSGB which causes nasty things to happen with no warnings or offers to reproject the data, I can work around that).

Other UKOS data used to be available as ESRI shape files but it looks like they’re moving over to GeoPackage and I’m having problems, the quarterly update of the postcode database is no longer supplied in ShapeFile format and I can’t persuade it to load the GeoPackage at all, the headers appear to be read OK but there are no features selected and no way to do so. The file is available here…

The OpenStreetMap tiles come through for the UK, distorted as expected, so at least the extent is read from the file, the data table has the correct headers but no data. The console shows these errors

1 Info APPLICATION STARTUP 05:50:02.878
2 Info Loading time: 00:00:04.2205058 05:50:07.263
3 Debug GDAL FAILURE: `D:\Users\PipzUK\Downloads\codepo_gpkg_gb (Nov 2020)\data\codepo_gb.gpkg’ not recognized as a supported file format. 05:50:33.130
4 Debug SQLiteCache::DoCaching: Failed to prepare statement. 05:50:33.715

with the last SQLite error being repeated many times.

So, it says the file format isn’t recognised - but it should be. From there things get even more strange. If I then close down MapWindow and reopen it (It’s set to reload the last map) the error messages change to

1 Info APPLICATION STARTUP 05:46:09.471
2 Info Loading time: 00:00:04.1787053 05:46:13.806
3 Debug OGR layer has single geometry type. ActiveShapeType provided will be ignored. 05:46:15.085
4 Info Project was loaded: D:\Users\PipzUK\Downloads\codepo_gb (Nov 2020)\cp2.mwproj 05:46:15.481
5 Debug SQLiteCache::DoCaching: Failed to prepare statement. 05:46:15.730
6 Debug 05:46:15.730

(again with the last SQLite error repeated many times)

So, this time it’s not claiming that it’s an unrecognised type - but it’s still not loading the data!

Ever wilder is trying the following…

Start with a blank map, drop the zoomstack package (the first file) and the package will open, on a UK map base.

Zoom in to a small (City-sized) area of the UK and drop the CodePoint (second file) on to the map. The map will resize to the UK extent and if the selected area was small enough the CodePoint dots will appear - zoom back in to the selected area to confirm this.

Now the really crazy part - right-click in the legend editor and remove the CodePoint layer - it will disappear from the legend editor but the dots on the map will stay, with no way to remove them!

Has anyone any suggestions?

[Further investigation]
Using the toolbox “Convert Vector” function I can convert the CodePoint GeoPackage to a shapefile and that adds to the map and behaves perfectly - it even offers to reproject it to work correctly with the map tiles! This makes me think that the package file is perfectly fine and MapWindow just isn’t handling packages as well as it might.